Posts Tagged ‘link’

Ninux.org e PresidioCelico, in difesa del territorio calabrese

Saturday, February 22nd, 2014

IMG_20140220_124908

L’isola cosentina della rete wireless comunitaria Ninux.org ha vissuto 2 mesi intensi, che l’hanno vista più che raddoppiare. Nella prossima settimana cercheremo di riassumervi tutti le nuove configurazioni, le idee dei nuovi membri della community, le prospettive eccitanti per il futuro. Ma adesso c’è qualcosa di più importante di cui vogliamo parlarvi,  qualcosa che arriva al cuore del concetto che crediamo essere alla base di una rete come Ninux, e che alimenta la nostra motivazione nello sviluppo di questa rete e di questo gruppo ben più di un innovativo protocollo di routing o di un link radio con un’attenuazione perfetta.

Lunedì i cittadini della presila cosentina si sono mossi per protestare contro le decisioni della regione Calabria in materia di rifiuti, preoccupati di pagare, in salute e in vivibilità del territorio, l’ennesima incuria nella gestione della cosa pubblica. La protesta è scattata nella notte di Lunedì, quando sempre più cittadini hanno cominciato, sfidando il freddo e la nebbia di questi giorni, ad occupare le via di accesso all’impianto di Celico. Tra questi il nostro fraticello, già nodo bello-che-attivo dell’isola NinuCS. Nel bel mezzo del nulla, quasi disconnessi da tutto nel momento in cui comunicare era più importante che mai, l’idea è stata questione di un attimo: perché non cortocircuitare una community per un’altra community?

IMG_20140220_162948È nato così, in meno di 30 ore, PresidioCelico. Un link radio di quasi 16km fino a Cerisano, il più lungo in Italia che non faccia parte dell’isola Ninux romana, che ha permesso al Presidio di dotarsi di una connettività stabile che ha reso più semplice aggiornarsi e aggiornare su quanto stava avvenendo con liveblogging e aggiornamenti sui social network, ma soprattutto un livestreaming dell’assemblea dei partecipanti, nella mattinata di Venerdì, con decine di collegamenti.

PresidioCelico, dopo 6 giorni e 5 notti di sit-in, non ha più resistito. Il suo lascito però, è importantissimo per Ninux Calabria. Innanzitutto è stata la conferma tangibile di ciò che abbiamo sempre professato: Ninux è una rete che mette al centro le persone. Sono le persone a possedere direttamente un pezzetto della rete, a gestirla e ad esserne parte attiva, invece che una minuscola e insignificante briciola alla periferia di Internet che se sparisse, non importerebbe niente a nessuno. L’importanza che ha essere produttori e non solo consumatori passivi di una rete la si vede proprio quando sono le necessità delle persone che devono essere ascoltate, specie dove collidono con logiche che ostacolano il cambiamento positivo e il benessere comune. Dove i provider Internet e i classici mass media non potevano o non volevano arrivare in supporto delle persone, Ninux c’era. La strada è quella giusta, PresidioCelico ci dice questo.

Infine PresidioCelico si lascia dietro un Nodo Nomade, con indirizzamento IP e apparati dedicati e pronti 24 ore su 24, che Ninux Calabria metterà a disposizione delle mobilitazioni cittadine come quella del Comitato Ambientale Presilano. Ma Ninux può arrivare solo fin dove ci sono cittadini pronti ad abbracciare questa rete libera e aperta. Prima di lasciarci con alcune foto della giornata dell’installazione, una dritta sui come passare i prossimi 10 minuti: leggi un po’ di Ninux sul wiki del progetto e se ti verrà voglia di entrare nella community e di amplificare l’innovazione tecnica e sociale di questa rete, faccelo sapere.

IMG_20140220_124817 IMG_20140220_124825 IMG_20140220_124831 IMG_20140220_124844 IMG_20140220_124852 IMG_20140220_124900 IMG_20140220_124914 IMG_20140220_124919 IMG_20140220_124924 IMG_20140220_124926 IMG_20140220_162904 IMG_20140220_162911 IMG_20140220_162922 IMG_20140220_162942 IMG_20140220_190611 IMG_20140220_190615 IMG_20140220_190617 IMG_20140220_190621 IMG_20140220_190624 IMG_20140220_192958 IMG_20140220_193007

Quarto link a Reggio Calabria

Thursday, November 21st, 2013

Eccolo!

calabria-4-link

 

PS, un reminder a tutti: non serve che scrivete post kilometrici!! Bastano delle immagini

Rotolando verso Sud

Monday, August 12th, 2013

Ed era già in programma da un po’… finalmente messo su ReggioCal::CampiGMP.

Nodo di Backbone, ovvero da un lato collegato con la Rocket di ReggioCal::BornAgain montata qualche giorno fa e quindi a tutta la rete fin qui creata. Dall’altra parte Access Point che guarda a Sud… Reggio Sud.

Ok, non sarà il fratello maggiore che starà alle sue spalle (nè vuole esserlo, non volendo essere commerciale), ma intanto fa il suo sporco lavoro…

20130807_193122

La visuale da questo nodo la trovate nella fotogallery dei nodi Ninux.

Abbiamo saltato la collina di Reggio centro e andiamo avanti… la Costa Jonica Reggina ci aspetta!

Capizzanux, avamposto di Ninux a Cosenza sud

Sunday, June 30th, 2013

All’ingresso dell’autostrada è nato Capizzanux, l’ultimo arrivato vive un test su Scooreggione e altre fantasmagoriche avventure, degne di un nodo di frontiera.

L'ingresso dell'autostrada. In alto a sinistra, dietro l'alberello, si scorge un palazzo opaco. Capizzanux è in quei paraggi.

L’ingresso dell’autostrada. In alto a sinistra, dietro l’alberello, si scorge un palazzo opaco. Capizzanux è in quei paraggi.

L’intenzione era latente. Quando i ragazzi dell’Hacklab hanno importato Ninux nella city la voce era giunta a Verdebinario e la curiosità lievitava, il desiderio prendeva forma, mancava però la spinta, il tetto, l’antenna… Insomma si è vergini anche in queste cose, quello che ci divide da una tecnologia non deriva forse da blandi fattori inibitori, incerti dubbi del tipo: la mia antenna sarà abbastanza alta e capace, mi scorno col vicino eppoi lavoro sprecato o ancora peggio: si ma poi che cci faccio co sto ninucs?

Il fu FPGDM-01

Il fattore spinta è nato a distanza di quasi un annetto: la realizzazione di un nodo per  HackIt 0×10. In altre parole la nuova sfida di Ninux è stato un banzai del tipo “o la va o la spacca” e a dirla tutta l’ha spaccata, in altre parole “non è andata”.

Il primo nodo, la sua utilità sociale è stata indirettamente proporzionale a quella tecnica. In altre parole non c'èrano i numeri...

Il primo nodo (FPGDM-01)

Quante volte, nel corso della vita, il senso di sconfitta diventa il motore delle cose, si pensi agli impianti idraulici senza i quali nessun bunga-bunga avrebbe visto luce, la testata di Zidane a Materazzi, la nascita del M5S, la perseveranza di Will Coyote. Così è stato. L’ubicazione dell’evento, in quel di Via Popilia, è stato sfavorevole, nella città i margini sono alti (es. Cosenza Sud) mentre il centro si approssima sempre più verso il letto del fiume Crati. Quell’antenna era praticamente nascosta in una fossa. Fine di Hackit0x10, fine dei giochi, smonta tutto e torna a casa.

nota:  test precedenti nell’area vennero fatti con gigismi,sul tetto del plesso difronte, chiedendo la corrente ai migranti che si dimostrarono entusiasti di un allaccio a 5ghz verso ninux.

Avere un binocolo è bene, vederci un albero un po meno

Inizia il test per Capizzanux. Si noti un "palo" telescopico della dexter, ispirato da quello mostratoci da lux nel corso del seminario ninux. La scala...A proposito, ma vedete anche voi lo stato terminale del tetto di casa mia, dovremmo indire una riunione condominiale...

Inizia il test per Capizzanux. Si noti un “palo” telescopico della dexter, (bella idea Lux !)

I test furono fatti di notte (disagio mentale+), per mezzo di una Nanostation M5 prestata dall’Hacklab. Il caso volle che un amico di una azienda cosentina dismetteva due Nanobridge M5 causa disuso, in quei giorni decisi di prenderle :)

Ecco il test decisivo sul punto più alto del palazzo. Il pratico netbook in una giornata dalle temperature miti

Ecco il test decisivo sul punto più alto del palazzo. Il pratico netbook in una giornata dalle temperature miti. Attenti al comignolo, sarà lui il protagonista.

I test condotti con la Nanostation m5 sono stati fatti verso SPIG, il nodo Ninux montato ai piedi di SanPietroInGuarano. Il segnale era attenuato a -73dbm, non proprio un affare. Poi vennero le piccole paraboline M300. Montare e smontare la Nanobridge mi ha fatto imprecare verso i suoi creatori. Quel pistone non vuole mai uscire e il cavo rimane prigioniero per sempre…

step 3: i test cunchiudono

Il test porta a inconfutabili certezze scientifiche: il segnale và meglio, sul palo arruginito, di mezzo metro più in basso; ma non chiedetemi il perchè…

Scoperta la posizione giusta con la Nanobridge e orientata la giusta inclinazione, dritta verso le fronde dell’alberello di fronte, il segnale si afferma a -68. La cosa ha spinto il sottoscritto a dire “vabè”, evitandomi di fravicare un palo per l’occasione.

Ingredienti: corrugato metri 6, cavo ftp cat5e metri 20, nasto isolante, chiave da 11, crimpatrice rj-45, plugs rj-45, grasso spray (la scivolina è per scolaretti), ascella commossa.

Ingredienti: corrugato metri 6, cavo ftp cat5e metri 20, nasto isolante, chiave da 11, crimpatrice rj-45, plugs rj-45, grasso spray (la scivolina è per scolaretti) e l’immancabile ascella commossa. I cavi sono due, ebbene in uno sporadico momento di lucidità ho pensato alla predisposizione per un’altra antenna…

Ecco il comignolo in disuso. Auguro a chiunque di ritrovarsene uno nei paraggi

Non indovinerete mai. Questo è quando ho iniziato ad infierire con scalpello e mazzetta (comprati per l'occasione)  sulle pareti vergini della cucina di casa mia. Domenica pomeriggio.

Questa opera prende il nome di “Inizio scalpello e mazzetta”. (Materiali comprati per l’occasione) prende forma sulle  “pareti vergini della cucina – domenica pomeriggio”.

Rompi tutto in profondità, tagliati per ravanare nell'oscurità di un pertugio stretto. Con un mestolo da cucina tenta di acchiappare i cavi, mangia fuliggine antica, tira fuori tutto. Sistema la cassetta, stucca, crimpa, testa.

Rompi tutto in profondità, guarda dentro. Con un mestolo da cucina acchiappa i cavi, fuliggine antica, tira fuori tutto. Sistema la cassetta, stucca, crimpa, testa.

La sistemazione e il cablaggio dei pin è stata un pochettino amara. Ho dovuto invertire i verdi con gli arancioni

La sistemazione e il cablaggio dei pin è stata un pochettino amara. Ho dovuto invertire i verdi con gli arancioni

Qui termina – volutamente – la galleria fotografica. Il cavo con tanto di canalina giunge al mobiletto networking centralizzato. Una ciabatta multi-interruttore con stickers mi offre un insano senso di onnipotenza, presto minato dai primi lancinanti dubbi…

  1. AirOS, il sistema operativo dell’antenna, è proprietario. Mh, loffio. Ninux è una rete dinamica e in continua evoluzione, richiede software open.
  2. Uploadare o non Uploadare? Sburratone o Scooreggione? Chi ha scelto questi nomi? Perché l’uno e non l’altro? Entrambi, in rapida successione, sarebbe cosa immorale?
  3. Se devo flashare dovrò smontare tutto? è un Attacco di panico?
  4. Routing manuale o mesh con OLSR? E le voci su Batman, su OSPF, su altri acronimi dissonanti… Dov’é la verità per l’uomo qualsiasi?

Sulla diatriba OLSR vs. Batman ho abbracciato questa pubblicazione, sebbene dicano grandi cose su OSPF ma non ho ancora condotto alcuna esperienza. Giungo vergine sul vetusto OLSR, figuriamoci il resto.

D’altronde la rete è fatta di standard e questi devono essere condivisi. Ninux Cosenza ha dato prova di stabilità con OLSR e come disse mio cugino prima di sposarsi: “Purché funzioni”.

Sull’upload posso dire di averlo fatto lasciando l’antenna sul tetto, rischiando tutto ma affindandomi ai test della comunità romana. A parte qualche domanda banale in lista il problema subito dopo il passaggio a Scooreggione è stato quello della compatibilità. Ovvero il supernodo di SanPietro aveva le estensioni AirMax attive. E’ bastato disabilitarle.

Sulla configurazione di OLSR ho dovuto comprendere bene la mappa della rete di Ninux Cosenza e questo ha richiesto un confronto con i padri fondatori della rete. Non pensavo di dover meshare anche l’interfaccia eth. Vabè, posto la configurazione per coloro i quali ci seguiranno in questa avventura Cosentina, a patto che la personalizzino coerentemente con i propri indirizzi.

/etc/config/network

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'lan'
option ifname 'eth0'
option proto 'static'
option ipaddr '10.87.x.x'
option netmask '255.255.255.0'

config interface 'backbone'
option proto 'static'
option ipaddr '172.17.87.x'
option netmask '255.255.0.0'
option dns '208.67.222.222'
option ifname 'wlan0'

/etc/config/wireless

config wifi-device radio0
#option type mac80211
#option channel 36
option type mac80211
option hwmode 11na
option macaddr 00:27:22:30:18:82
option htmode HT40+
list ht_capab SHORT-GI-40
list ht_capab TX-STBC
list ht_capab RX-STBC1
list ht_capab DSSS_CCK-40
# REMOVE THIS LINE TO ENABLE WIFI:
#option disabled 1
option distance 5000
config wifi-iface
option device radio0
option network backbone
option mode sta
option ssid calabria.ninux.org
option encryption none

/etc/config/olsrd

config olsrd
option IpVersion '4'
option RtTable '111'
option RtTableDefault '112'

config LoadPlugin
option library 'olsrd_arprefresh.so.0.1'

config LoadPlugin
option library 'olsrd_nameservice.so.0.3'

config LoadPlugin
option library 'olsrd_txtinfo.so.0.1'
option accept '0.0.0.0'

config Interface
list interface 'lan backbone'
option speed '6'

config Hna4
option netaddr '10.87.7.0'
option netmask '255.255.255.0'

…Ah, dimenticavo. in /etc/rc.local, quì a Cosenza, eliminiamo la blackhole a 10.0.0.0; abbiamo preparato un posto al caldo lì, non rinunciateci, vi stiamo aspettando.

Inoltre Capizzanux vede Cerisano a circa 5km di distanza, chi di Cerisano cogliesse la palla al balzo si aggiudicherà un peer su misura… Magari gli sistemiamo una bella Rocket su un palo telescopico nuovo di zecca, mantenuto da sostegni per montature pesanti, insomma, come diciamo qui a Cosenza: vai mò.

Cosenza è un’isola

Tuesday, June 4th, 2013

Non vi torna? Un’isola Ninux, ovviamente! Ecco la classica immagine che vale più di mille parole:

Il supernodo di SPIG unito ai nodi foglia dell'HPCC, di Spax e Vin-San.

Il supernodo di SPIG unito ai nodi foglia dell’HPCC, di Spax e Vin-San.

Il progetto Ninux Calabria è nato a Cosenza, e da qui i fondatori del progetto l’hanno portato in pochissimo tempo a far nascere le isole di Catanzaro e di Reggio Calabria. Per quella cosentina ci sono stati più intoppi di quello che avremmo voluto ma ora ci siamo! L’isola cosentina conta circa 11km di collegamenti wireless, è la più estesa finora in Calabria, e come ognuna delle isole dalle quali è formata la rete Ninux (oltre a Roma ce ne sono a Pisa, Firenze, Vicenza, Viterbo, Ragusa e Mistretta) è collegata alla rete nazionale attraverso un tunnel VPN.

San Pietro In Guarano: Supernode!

La parte cruciale dell’isola Ninux di Cosenza è il nuovo supernodo posto a Padula, frazione del comune di San Pietro in Guarano (SPIG). Ecco una bella prospettiva di Cosenza dall’accoppiata Rocket M5 + Antenna AirMax Sector 16 dBi-120°:

SPIG SuperNode 1Tutto questo è stato reso possibile dalla collaborazione di Gianluca, un ragazzo che da tempo opera nella zona come WISP (Wireless Internet Service Provider) e che si è interessato da subito al progetto Ninux Calabria, portando il suo vasto know-how e il suo entusiasmo.

Potete trovare tutte le foto del montaggio a SPIG, incluse tantissime panoramiche dell’area visibile dal nodo (l’apertura dell’antenna dovrebbe coprire un’area che va da Settimo fino all’area del tribunale) nella fotogallery di Ninux.

HPCC

La Nanostation M5 montata al nostro laboratorio in Unical ha mantenuto la stessa configurazione di qualche tempo fa, ma ora è stata riconfigurata per puntare verso SPIG e ottenere dunque il primo link dell’isola cosentina.

Spax

Abitare in mansarda non ha tantissimi lati positivi. A meno che una delle tue passioni non siano le reti wireless comunitarie. Nel qual caso una Nanostation M5 potrebbe spuntare tra i panni stesi.

Nodo SpaxVin-San

L’ultimo arrivato nell’isola, a completare quella che al momento è praticamente una mini-rete tra le location cosentine dei membri dell’Hacklab Cosenza. Ecco due panoramiche della sua Nanostation M5, comodamente montata sul suo balconcino.

nodo vin-san 1nodo vin-san 2

Eccola qui la nostra Isola!

Al momento è operativa e funzionante, anche se le prestazioni non sono per ora quelle che speravamo, molto probabilmente a causa dell’elevato traffico a 5 GHz presente nella zona. Ci sarà da lavorare per pulire il segnale, ma è l’inizio che speravamo.