Posts Tagged ‘Cosenza’

Benvenuto Lappanux, nuovo supernodo NinuCS

Wednesday, July 23rd, 2014

Da poco l’hardware team calabro (thank you Musk, PeppeLinux, Vilgio Big Hat e Stefanauss) ha attivato una nuova location a Lappano (Santo Stefano), in grado di coprire tutta Cosenza da Nord a Sud. Guardare per credere.

La panoramica del supernodo Lappanux. Non male, eh?

La panoramica del supernodo Lappanux. Non male, eh?

Si tratta di un supernodo creato, mantenuto e finanziato in combo da più membri della community cosentina, un bell’accenno di crowdfunding ninuxaro! Abbiamo anche imparato tanto, soprattutto uno dei principi basilari dei montaggi Ninux: chi più spende, meno spende. All’inizio avevamo acquistato antenne usate, di seconda mano, che da subito hanno performato male: flapping della Ethernet, radio presente a tratti, un disastro. Il primo “viaggio” ha posizionato tutto, ma non ha prodotto risultati in fin dei conti.

lappanux_peppe

Più che una corda sembrano le mie bretelle impigliate.

Per il secondo abbiamo fatto tesoro della lezione e siamo tornati ad apparati nuovi, testati e configurati in precedenza con tutta calma. Riconfigurato il router con ground routing da manuale, montato in una cassetta trasparente a tenuta stagna assieme ai POE, e aggiunto un braccetto per distanziare ulteriormente le antenne. Risultato perfetto!

Una volta tirati sù i cavi guainati il più è fatto

Una volta tirati sù i cavi guainati e le antenne sul palo siamo al 50% del lavoro. Seguono puntamento e routing test.

Lappanux è pronto per accogliervi in questa community libera, aperta, costruita dal basso. Puntando verso Lappanux troverete due SSID,

  • nord.lappanux.calabria.ninux.org – Ubiquiti Rocket M5 + Sector 90° 17 dBi
  • sud.lappanux.calabria.ninux.org – Ubiquiti NanoStation M5

Presto verrà installata una terza antenna direttiva che farà da dorsale punto-punto verso gli altri supernodi cosentini.

Un test veloce per linkarlo dall'esterno...

Un test veloce per linkarlo dall’esterno…

Su Lappanux abbiamo disabilitato le estensioni proprietarie della Ubiquiti (che spariranno presto anche a San Pietro in Guarano), pertanto qualsiasi apparato 802.11 abbiate che operi nei 5 GHz vi consentirà di collegarvi.

... concretizzato con una insonne airGrid, -72db  120 Mbps, CCQ 100%

… concretizzato con una insonne airGrid, -72db 120 Mbps, CCQ 100%

Come al solito vi aspettiamo nuovi Ninuxer, virtualmente sulla ML (“Contattaci” nel menu) e fisicamente ogni Martedì alle 19 all’Unical (Cubo 22).

lappanux2

E’ forse l’obiettivo del cellulare o quella Rocket pare troppo inclinata in basso… Vedremo, intanto saluti da Lappano.

Internet Condominiale e Ninux

Saturday, May 17th, 2014

La rete del Nodo Capizzanux 10.87.7.0/24 è stata affiancata da un’altra rete, 10.87.12.0/24, quando è nata l’idea di realizzare un InternetCondominiale.

L’InternetCondominiale è un servizio accessibile a chi aderisce alle spese dell’utenza mentre l’accesso alla rete Ninux è libero per tutti.

IMG_20140517_113025

Se la paura dei “ladri” non ci avesse intimorito, l’access point sarebbe stato sistemato più in basso rispetto al soffitto… Ma sta funzionando bene !

Alla condivisione dei costi dell’utenza, e al progetto nella sua totalità, hanno aderito fin’ora 4 famiglie. L’opportunità derivante dal collegamento alla rete Ninux consente anche a parenti o amici, delle famiglie aderenti al progetto, di condividere i costi ed i benefici della rete condominiale anche da locali distanti kilometri dal condominio Capizzano (grazie ancora Ninux!). Questa opportunità ci consente di prevedere almeno due nuove famiglie aderenti al progetto nei prossimi mesi.

Le famiglie che aderiscono al progetto abitano tutte in locali vicini. L’opportunità di sistemare altri due access point all’interno delle scale del condominio attende solo l’adesione di una o più famiglie dei piani inferiori.

Selezione_006


Il progetto Ninux consente ad ogni nodo di comunicare con tutti gli altri indipendentemente dal link rf diretto che ogni antenna ha con il proprio AccessPoint

Segue la descrizione della lettera che comunica al condominio la realizzazione dell’opera:

Oggetto:
Comunicazione connettività Internet – rete Comunitaria Condominiale

I Signori Condomini possessori di uno o più computer, smatphone, tablet o televisione di ultima generazione, sono informati che a decorrere dal giorno 8 Marzo 2014 potranno usufruire di una connessione Wireless, o via cavo (UTP 8 Cat5e), per accedere a servizi telematici locali al condominio, quali l’accesso ad internet.

Per servizi telematici locali si possono anche intendere:

Videosorveglianza
Streaming Audio/Video ( Film, televisione, Voip )
Condivisione di servizi (quali ADSL e altro)

1. Opere di realizzazione
Per realizzare la rete locale condominiale è stato installato al sesto piano del fabbricato, al quale l’opera è riferita, un dispositivo di tipo AccessPoint 2,4Ghz con un numero di porte ethernet pari alle abitazioni di un pianerottolo + 1.

Per la connettività Internet è stato installato un Router ATM.
Per la connettività alla rete Comunitaria Nazionale Ninux è stato installato un dispositivo CPE outdoor.

2. Costi di realizzazione
Il materiale utilizzato è composto da una AccessPoint/Router marca TP-LINK, modello TL-WR841ND pari ad un costo di 20€. Per l’ installazione di questo dispositivo sono stati utilizzati 20 metri di cavo elettrico di rete tripolare da 0.75mm2 ad un costo di 11€, un connettore di corrente di rete maschio pari ad un costo di 1€, due sezioni di cavo F/UTP pari a 45 metri totali ad un costo di ( 0.40 * 45 ) 18€, 4 plug RJ-45 per il cablaggio pari a 1,60€ . Tale spesa è stata ripartita tra il Condomino GDM e la Famiglia T. rappresentata dal Condomino F.T., ed è offerta gratuitamente a tutti i futuri utilizzatori così come è.

L’ opera così descritta consente ai condomini di comunicare l’un l’altro in una LAN.
Per l’accesso ad internet è stato sottoscritto un contratto telefonico/ADSL intestato al condomino GDM, per il quale egli riveste il ruolo di intestatario e rappresentante legale nei confronti del gestore telefonico Wind/Infostrada. Il contratto ha un costo una tantum di 20,59€ + 70,23€, rispettivamente la tassa sul cartaceo del bollettino bimensile e il costo di attivazione della nuova linea. Tale costo è stato sostenuto dall’intestatario in via gratuita.

Per l’accesso alla rete geografica Ninux è stato installato un dispositivo marca Ubiquity modello NanoBridge M5 e un router marca TP-LINK, modello TL-WR1043ND con cablaggi e supporti, tutti ad uso privato dell’intestatario ma condivisi gratuitamente alla realizzazione del progetto in oggetto.

Ogni dispositivo è attualmente collegato alla utenza di rete elettrica privata dell’intestatario dei contratti ad eccezione dell’ AccessPoint installato al 6° piano che è collegato all’utenza di rete della famiglia Torano.

3. Usi e benefici

La rete locale LAN così realizzata consente i seguenti casi di uso:

Condivisione di Internet tra Condomini che alloggiano in locali differenti senza alcun costo monetario.
Condivisione di Internet tra un Condomino e un suo parente/amico/collaboratore che alloggia in locale sito tra il comune di Settimo di Montalto e Spezzano della Sila, comprendente tutta l’area urbana ove il Link alla rete Ninux sia effettivamente possibile ( buona visuale dell’aria urbana ). Nessun costo monetario.
Uso del contratto di ADSL Condominiale. Costo ripartito equamente tra i partecipanti.

4. Modalità di partecipazione

Ogni Condomino può estendere la rete all’interno del fabbricato secondo le regole condominiali e quelle del buon senso, seguite dal confronto in assemblea condominiale o delega. Ogni Condomino può fare richiesta di accesso rivolgendosi all’amministratore Condominiale o ai condomini GDM, FT o RS, i quali provvederanno a comunicare le credenziali di accesso appena possibile.

5. Caratteristiche della rete

La rete LAN è una comune rete switched/wireless fino a 100mbit di banda.
La rete Ninux è una rete Switched Mesh fino a 260mbit di banda.
La rete Internet Condominiale è una rete ADSL fino a 14megabit/1megabit di banda.

6. Condomini attualmente connessi

Attualmente usufruiscono del servizio i seguenti:

Famiglia DIR
Famiglia T
GDM
Famiglia DC

7. Garanzie di servizio

Eventuali guasti della connessione ADSL possono essere tollerati sfruttando connessioni di emergenza sulla rete Geografica Ninux. Eventuali problemi tecnici di caso specifico possono essere espressi ed evasi con spirito di reciprocità e condivisione fra i partecipanti al progetto, con particolare attenzione agli impegni, alle priorità e al livello tecnico di ciascuna delle parti aderenti al progetto.

8. Note tecniche

Il modello di CPE outdoor installato all’esterno del fabricato ricalca le seguenti caratteristiche tecniche:

Processore: – Atheros MIPS 24KC operante a 400 MHz
Memoria: – 32 MB SDRAM – 8 MB Flash
Connessioni di rete: – 1 porta Ethernet 10/100 Mbps
Frequenze operative : – 5470 MHz ~ 5825 MHz
Dimensioni: – 163 x 31 x 80mm
Peso: – 180 grammi
Consumo: – 5.5 Watt
Alimentazione: – Tramite PoE
Temperature supportate: – da -30°C a +80°C
Frequenze supportate: – da 5.47 GHz a 5.825 GHz
Guadagno: – 13dBi
Polarizzazione: – Duplice (Orizzontale + Verticale)
VSWR: – 1.4:1 max

9. Riferimenti

Ulteriori informazioni sulla rete comunitaria Ninux sono disponibili presso l’url:

http://ninux.org

IMG_20140517_112924


Saluti da Capizzanux :)

Ninux.org e PresidioCelico, in difesa del territorio calabrese

Saturday, February 22nd, 2014

IMG_20140220_124908

L’isola cosentina della rete wireless comunitaria Ninux.org ha vissuto 2 mesi intensi, che l’hanno vista più che raddoppiare. Nella prossima settimana cercheremo di riassumervi tutti le nuove configurazioni, le idee dei nuovi membri della community, le prospettive eccitanti per il futuro. Ma adesso c’è qualcosa di più importante di cui vogliamo parlarvi,  qualcosa che arriva al cuore del concetto che crediamo essere alla base di una rete come Ninux, e che alimenta la nostra motivazione nello sviluppo di questa rete e di questo gruppo ben più di un innovativo protocollo di routing o di un link radio con un’attenuazione perfetta.

Lunedì i cittadini della presila cosentina si sono mossi per protestare contro le decisioni della regione Calabria in materia di rifiuti, preoccupati di pagare, in salute e in vivibilità del territorio, l’ennesima incuria nella gestione della cosa pubblica. La protesta è scattata nella notte di Lunedì, quando sempre più cittadini hanno cominciato, sfidando il freddo e la nebbia di questi giorni, ad occupare le via di accesso all’impianto di Celico. Tra questi il nostro fraticello, già nodo bello-che-attivo dell’isola NinuCS. Nel bel mezzo del nulla, quasi disconnessi da tutto nel momento in cui comunicare era più importante che mai, l’idea è stata questione di un attimo: perché non cortocircuitare una community per un’altra community?

IMG_20140220_162948È nato così, in meno di 30 ore, PresidioCelico. Un link radio di quasi 16km fino a Cerisano, il più lungo in Italia che non faccia parte dell’isola Ninux romana, che ha permesso al Presidio di dotarsi di una connettività stabile che ha reso più semplice aggiornarsi e aggiornare su quanto stava avvenendo con liveblogging e aggiornamenti sui social network, ma soprattutto un livestreaming dell’assemblea dei partecipanti, nella mattinata di Venerdì, con decine di collegamenti.

PresidioCelico, dopo 6 giorni e 5 notti di sit-in, non ha più resistito. Il suo lascito però, è importantissimo per Ninux Calabria. Innanzitutto è stata la conferma tangibile di ciò che abbiamo sempre professato: Ninux è una rete che mette al centro le persone. Sono le persone a possedere direttamente un pezzetto della rete, a gestirla e ad esserne parte attiva, invece che una minuscola e insignificante briciola alla periferia di Internet che se sparisse, non importerebbe niente a nessuno. L’importanza che ha essere produttori e non solo consumatori passivi di una rete la si vede proprio quando sono le necessità delle persone che devono essere ascoltate, specie dove collidono con logiche che ostacolano il cambiamento positivo e il benessere comune. Dove i provider Internet e i classici mass media non potevano o non volevano arrivare in supporto delle persone, Ninux c’era. La strada è quella giusta, PresidioCelico ci dice questo.

Infine PresidioCelico si lascia dietro un Nodo Nomade, con indirizzamento IP e apparati dedicati e pronti 24 ore su 24, che Ninux Calabria metterà a disposizione delle mobilitazioni cittadine come quella del Comitato Ambientale Presilano. Ma Ninux può arrivare solo fin dove ci sono cittadini pronti ad abbracciare questa rete libera e aperta. Prima di lasciarci con alcune foto della giornata dell’installazione, una dritta sui come passare i prossimi 10 minuti: leggi un po’ di Ninux sul wiki del progetto e se ti verrà voglia di entrare nella community e di amplificare l’innovazione tecnica e sociale di questa rete, faccelo sapere.

IMG_20140220_124817 IMG_20140220_124825 IMG_20140220_124831 IMG_20140220_124844 IMG_20140220_124852 IMG_20140220_124900 IMG_20140220_124914 IMG_20140220_124919 IMG_20140220_124924 IMG_20140220_124926 IMG_20140220_162904 IMG_20140220_162911 IMG_20140220_162922 IMG_20140220_162942 IMG_20140220_190611 IMG_20140220_190615 IMG_20140220_190617 IMG_20140220_190621 IMG_20140220_190624 IMG_20140220_192958 IMG_20140220_193007

[Rassegna Stampa] “Ninux, un altro web”, Corriere della Calabria del 10 Ottobre

Friday, October 4th, 2013

Cliccando sulle immagini potrete leggere direttamente la scansione dell’articolo e visualizzare le fotografie incluse, tra cui una del nostro BornAgain che ha condotto gran parte dell’intervista, mentre in basso trovate la trascrizione completa del pezzo per la comoda lettura via web. In alternativa potete scaricare il PDF. Buona lettura!

ninux-corriere-calabria-pag1 ninux-corriere-calabria-pag2COMUNITÀ VIRTUALI

Ninux, un altro web

È una rete wireless in cui i partecipanti comunicano e scambiano contenuti. È alternativa a internet. I suoi “nodi” adesso spuntano anche in Calabria

di Alessia Candito

In barba alle statistiche che relegano la Calabria in fondo alle classifiche di alfabetizzazione informatica e sul podio del digital divide italiano, ci sono anche (pochi) calabresi fra i pionieri della rete alternativa a internet che, nodo dopo nodo, sta colorando la penisola. Si chiama Ninux e tecnicamente si tratta di una meshnet, una wireless privata, i cui partecipanti possono comunicare tra loro, scambiare file, mettere in comune contenuti, risorse o servizi, far viaggiare video, foto, informazioni in modo del tutto indipendente da quella che è comunemente conosciuta come Rete. Per entrarci e diventare quello che in gergo si definisce “nodo” bastano un’antenna radio, un normale router e le conoscenza tecniche necessarie per collegarsi alla cosiddetta “isola”, l’insieme dei nodi presenti nel proprio territorio. Anzi, spiega Dario Stelitano, reggino, dottorando In Fisica all’Università di Potenza e fra i pionieri della rete alternativa calabrese, le conoscenze tecniche non sono neanche strettamente necessarie perché «Ninux è prima di tutto una comunità, un insieme di persone che – ognuna con le proprie competenze, ognuna con le proprie capacità — hanno deciso di unirsi per costruire un’infrastruttura su cui far viaggiare liberamente delle informazioni, al di fuori delle strade note». E proprio le strade sono l’esempio più calzante per spiegare la filosofia di questa nuova “rete delle reti” che piano piano sta conquistando l’Italia. «È come se ogni partecipante alla rete, quindi ogni nodo costruisse il suo pezzetto di strada che si collega alle altre che i suoi vicini stanno realizzando, ma nessuno ci mette un cancello o un pedaggio. Alla fine tutti quelli che partecipano alla costruzione della strada possono viaggiarci liberamente: questo è Ninux. Ogni partecipante, ogni nodo, contribuisce alla costruzione di una infrastruttura di rete che permette a tutti di comunicare con tutti, gratuitamente». Ma soprattutto, a differenza di quanto succede con un provider commerciale — i vari operatori telefonici che offrono l’accesso alla rete – si possono caricare e scaricare contenuti alla stessa velocità. «È una basilare questione di democrazia – sottolinea Stelitano – in Ninux i contenuti con cui io arricchisco la rete hanno lo stesso valore di quelli a cui io posso accedere. Su Internet no. L’apporto che come utente potrò dare sarà sempre inferiore a quello — ormai in larga parte commerciale e a pagamento – che viaggia in rete. Con Ninux, la rete è neutrale, non appannaggio dei provider».

Giuridicamente — spiega il manifesto italiano — questa nuova rete è equivalente ad un «gruppo di amici che si vede la sera sotto casa, discute di sport e talvolta si organizza per giocare a calcetto o farsi una “braciolata” in campagna». Volutamente, almeno per adesso, i pionieri di Ninux hanno deciso di non trasformarlo in una associazione o una fondazione, evitando qualsiasi tipo di pastoia burocratica. «E come una intranet diffusa — chiarisce ancora Siciliano — solo che invece di rimanere confinata in un ufficio o in un palazzo, è a disposizione della comunità».
Non si tratta di un esperimento isolato. Le prime reti di questo genere sono nate negli Stati Uniti alla fine degli anni 90, ma rapidamente si sono diffuse anche in Europa. La Gufi spagnola è una delle più sviluppate, ma anche i tedeschi sono riusciti progressivamente ad estendere la loro da Berlino a quasi tutto il Paese.
In Italia, l’esperimento è partito nella capitale — attualmente l’isola più grande e in grado di fornire più servizi — ma si sta progressivamente estendendo in tutta la penisola. 0ggi ci sono isole di Ninux a Roma, Vicenza. Pisa. Viterbo. Mistrena, Firenze e in Friuli Venezia Giulia. La Calabria è una delle prime regioni ad aver aderito al progetto. «I primi esperimenti — ricostruisce Stelitano — sono nati addirittura una decina di anni fa., ma Ninux ha cominciato concretamente ad essere costruito più o meno un anno e mezzo fa. A fare da catalizzatore al progetto è stato l’Hacklab — la comunità degli hacker – dell’Università di Cosenza – i primi esperimenti sono iniziati lì. Poi ognuno di noi ha costruito un’isola nel proprio territorio».
«Qui a Cosenza, Ninux attualmente riunisce soprtattutto studenti universitari, quindi anche i servizi che abbiamto sviluppato sono relativi a quest’ambito — interviene Stefano De Carlo, collegato in videochat — ma si stanno avvicinando anche persone estranee all’originario gruppo di appassionati di tecnologia che ha dato vita al primo nodo. Nei prossimi mesi, il nostro obiettivo è raggiungere il maggior numero di persone possibile. anche perché uno dei punti di forza di Ninux è che più cresce la rete, più cresce la comunità, maggiori sono i servizi e le opportunità che la comunità stessa ha a disposizione». Un percorso simile anche se in scala ridotta, a quello dell’isola di Catanzaro, nata attorno all’Hacklab e che oggi — piano piano – cerca di coinvolgere anche profani della tecnologia, aggiunge Luigi Smiraglio. «Noi — dice — stiamo cercando di far capire che entrare in Ninux è come decidere di fare il pane a casa. Il sapore e simile a quello dei panifici, ma si possono selezionare gli ingredienti migliori. E soprattutto, non sono le logiche di mercato a stabilire quali siano». L’esperienza reggina invece è partita in maniera diversa. Sulla riva dello Stretto non c’era nessun hacklab cui appoggiarsi per cui si è deciso fin da subito di rivolgersi a una platea di “non addetti ai lavori”. «Qui – spiega Gianni Polimeni, uno dei pionieri del nodo reggino — abbiamo iniziato fin da subito una collaborazione con il gruppo astrofili, infatti uno degli obiettivi per il prossimo anno è la relizzazione di un server che permetta ai vari partecipanti di lavorare da casa sulle stesse fotograie che scattiamo con il telescopio dell’osservatorio». Ma al di là dei progetti specifici, in via di avviamento c’è anche Asterics, un servizio che permette di fare chiamate gratuite fra i partecipanti dell’isola reggina, ma soprattutto – quanto meno in prospettiva — lo sviluppo di Nìnux come infrastruttura di comunicazione di emergenza. «In un territorio sismico come il nostro, in caso di calamità o disastri naturali, la nostra meshnet potrebbe funzionare anche se le reti garantite dagli operatori cadessero», aggiunge Stelitano.

Una vocazione sociale non limitata al territorio reggino, ma che permea tutto lo spirito del progetto.
«Se nel corso delle primavere arabe ci fosse stata la possibilità di avere una rete mesh — dice Stefano Pirrone – per i manifestanti sarebbe stato molto più facile far filtrare i contenuti sulla grande stampa o comunque farli circolare, perché i governi non avrebbero potuto buttarle giù». Inoltre, sottolinea ancora, «lo scandalo del Nsa e le rivelazioni di Snowden, hanno rivelato che Internet è fondamentalmente una rete che si basa sulla fiducia, perché le informazioni viaggiano criptate con codici che sono di proprietà di ditte per lo più americane. Ma agenzie come la Nsa o le varie agenzie antiterrorismo conoscono già tutte le chiavi di crittografia, quindi hanno già violato alla base questo protocollo di fiducia. È impossibile mettere in sicurezza Internet, va ripensata ma è impossibile farlo rimanendo all’interno di Internet stesso. Le reti che guideranno la sperimentazione per un web veramente sicuro e in grado di garantire il fondamentale diritto alla privacy sono le reti mesh come Ninux».

Capizzanux, avamposto di Ninux a Cosenza sud

Sunday, June 30th, 2013

All’ingresso dell’autostrada è nato Capizzanux, l’ultimo arrivato vive un test su Scooreggione e altre fantasmagoriche avventure, degne di un nodo di frontiera.

L'ingresso dell'autostrada. In alto a sinistra, dietro l'alberello, si scorge un palazzo opaco. Capizzanux è in quei paraggi.

L’ingresso dell’autostrada. In alto a sinistra, dietro l’alberello, si scorge un palazzo opaco. Capizzanux è in quei paraggi.

L’intenzione era latente. Quando i ragazzi dell’Hacklab hanno importato Ninux nella city la voce era giunta a Verdebinario e la curiosità lievitava, il desiderio prendeva forma, mancava però la spinta, il tetto, l’antenna… Insomma si è vergini anche in queste cose, quello che ci divide da una tecnologia non deriva forse da blandi fattori inibitori, incerti dubbi del tipo: la mia antenna sarà abbastanza alta e capace, mi scorno col vicino eppoi lavoro sprecato o ancora peggio: si ma poi che cci faccio co sto ninucs?

Il fu FPGDM-01

Il fattore spinta è nato a distanza di quasi un annetto: la realizzazione di un nodo per  HackIt 0×10. In altre parole la nuova sfida di Ninux è stato un banzai del tipo “o la va o la spacca” e a dirla tutta l’ha spaccata, in altre parole “non è andata”.

Il primo nodo, la sua utilità sociale è stata indirettamente proporzionale a quella tecnica. In altre parole non c'èrano i numeri...

Il primo nodo (FPGDM-01)

Quante volte, nel corso della vita, il senso di sconfitta diventa il motore delle cose, si pensi agli impianti idraulici senza i quali nessun bunga-bunga avrebbe visto luce, la testata di Zidane a Materazzi, la nascita del M5S, la perseveranza di Will Coyote. Così è stato. L’ubicazione dell’evento, in quel di Via Popilia, è stato sfavorevole, nella città i margini sono alti (es. Cosenza Sud) mentre il centro si approssima sempre più verso il letto del fiume Crati. Quell’antenna era praticamente nascosta in una fossa. Fine di Hackit0x10, fine dei giochi, smonta tutto e torna a casa.

nota:  test precedenti nell’area vennero fatti con gigismi,sul tetto del plesso difronte, chiedendo la corrente ai migranti che si dimostrarono entusiasti di un allaccio a 5ghz verso ninux.

Avere un binocolo è bene, vederci un albero un po meno

Inizia il test per Capizzanux. Si noti un "palo" telescopico della dexter, ispirato da quello mostratoci da lux nel corso del seminario ninux. La scala...A proposito, ma vedete anche voi lo stato terminale del tetto di casa mia, dovremmo indire una riunione condominiale...

Inizia il test per Capizzanux. Si noti un “palo” telescopico della dexter, (bella idea Lux !)

I test furono fatti di notte (disagio mentale+), per mezzo di una Nanostation M5 prestata dall’Hacklab. Il caso volle che un amico di una azienda cosentina dismetteva due Nanobridge M5 causa disuso, in quei giorni decisi di prenderle :)

Ecco il test decisivo sul punto più alto del palazzo. Il pratico netbook in una giornata dalle temperature miti

Ecco il test decisivo sul punto più alto del palazzo. Il pratico netbook in una giornata dalle temperature miti. Attenti al comignolo, sarà lui il protagonista.

I test condotti con la Nanostation m5 sono stati fatti verso SPIG, il nodo Ninux montato ai piedi di SanPietroInGuarano. Il segnale era attenuato a -73dbm, non proprio un affare. Poi vennero le piccole paraboline M300. Montare e smontare la Nanobridge mi ha fatto imprecare verso i suoi creatori. Quel pistone non vuole mai uscire e il cavo rimane prigioniero per sempre…

step 3: i test cunchiudono

Il test porta a inconfutabili certezze scientifiche: il segnale và meglio, sul palo arruginito, di mezzo metro più in basso; ma non chiedetemi il perchè…

Scoperta la posizione giusta con la Nanobridge e orientata la giusta inclinazione, dritta verso le fronde dell’alberello di fronte, il segnale si afferma a -68. La cosa ha spinto il sottoscritto a dire “vabè”, evitandomi di fravicare un palo per l’occasione.

Ingredienti: corrugato metri 6, cavo ftp cat5e metri 20, nasto isolante, chiave da 11, crimpatrice rj-45, plugs rj-45, grasso spray (la scivolina è per scolaretti), ascella commossa.

Ingredienti: corrugato metri 6, cavo ftp cat5e metri 20, nasto isolante, chiave da 11, crimpatrice rj-45, plugs rj-45, grasso spray (la scivolina è per scolaretti) e l’immancabile ascella commossa. I cavi sono due, ebbene in uno sporadico momento di lucidità ho pensato alla predisposizione per un’altra antenna…

Ecco il comignolo in disuso. Auguro a chiunque di ritrovarsene uno nei paraggi

Non indovinerete mai. Questo è quando ho iniziato ad infierire con scalpello e mazzetta (comprati per l'occasione)  sulle pareti vergini della cucina di casa mia. Domenica pomeriggio.

Questa opera prende il nome di “Inizio scalpello e mazzetta”. (Materiali comprati per l’occasione) prende forma sulle  “pareti vergini della cucina – domenica pomeriggio”.

Rompi tutto in profondità, tagliati per ravanare nell'oscurità di un pertugio stretto. Con un mestolo da cucina tenta di acchiappare i cavi, mangia fuliggine antica, tira fuori tutto. Sistema la cassetta, stucca, crimpa, testa.

Rompi tutto in profondità, guarda dentro. Con un mestolo da cucina acchiappa i cavi, fuliggine antica, tira fuori tutto. Sistema la cassetta, stucca, crimpa, testa.

La sistemazione e il cablaggio dei pin è stata un pochettino amara. Ho dovuto invertire i verdi con gli arancioni

La sistemazione e il cablaggio dei pin è stata un pochettino amara. Ho dovuto invertire i verdi con gli arancioni

Qui termina – volutamente – la galleria fotografica. Il cavo con tanto di canalina giunge al mobiletto networking centralizzato. Una ciabatta multi-interruttore con stickers mi offre un insano senso di onnipotenza, presto minato dai primi lancinanti dubbi…

  1. AirOS, il sistema operativo dell’antenna, è proprietario. Mh, loffio. Ninux è una rete dinamica e in continua evoluzione, richiede software open.
  2. Uploadare o non Uploadare? Sburratone o Scooreggione? Chi ha scelto questi nomi? Perché l’uno e non l’altro? Entrambi, in rapida successione, sarebbe cosa immorale?
  3. Se devo flashare dovrò smontare tutto? è un Attacco di panico?
  4. Routing manuale o mesh con OLSR? E le voci su Batman, su OSPF, su altri acronimi dissonanti… Dov’é la verità per l’uomo qualsiasi?

Sulla diatriba OLSR vs. Batman ho abbracciato questa pubblicazione, sebbene dicano grandi cose su OSPF ma non ho ancora condotto alcuna esperienza. Giungo vergine sul vetusto OLSR, figuriamoci il resto.

D’altronde la rete è fatta di standard e questi devono essere condivisi. Ninux Cosenza ha dato prova di stabilità con OLSR e come disse mio cugino prima di sposarsi: “Purché funzioni”.

Sull’upload posso dire di averlo fatto lasciando l’antenna sul tetto, rischiando tutto ma affindandomi ai test della comunità romana. A parte qualche domanda banale in lista il problema subito dopo il passaggio a Scooreggione è stato quello della compatibilità. Ovvero il supernodo di SanPietro aveva le estensioni AirMax attive. E’ bastato disabilitarle.

Sulla configurazione di OLSR ho dovuto comprendere bene la mappa della rete di Ninux Cosenza e questo ha richiesto un confronto con i padri fondatori della rete. Non pensavo di dover meshare anche l’interfaccia eth. Vabè, posto la configurazione per coloro i quali ci seguiranno in questa avventura Cosentina, a patto che la personalizzino coerentemente con i propri indirizzi.

/etc/config/network

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'lan'
option ifname 'eth0'
option proto 'static'
option ipaddr '10.87.x.x'
option netmask '255.255.255.0'

config interface 'backbone'
option proto 'static'
option ipaddr '172.17.87.x'
option netmask '255.255.0.0'
option dns '208.67.222.222'
option ifname 'wlan0'

/etc/config/wireless

config wifi-device radio0
#option type mac80211
#option channel 36
option type mac80211
option hwmode 11na
option macaddr 00:27:22:30:18:82
option htmode HT40+
list ht_capab SHORT-GI-40
list ht_capab TX-STBC
list ht_capab RX-STBC1
list ht_capab DSSS_CCK-40
# REMOVE THIS LINE TO ENABLE WIFI:
#option disabled 1
option distance 5000
config wifi-iface
option device radio0
option network backbone
option mode sta
option ssid calabria.ninux.org
option encryption none

/etc/config/olsrd

config olsrd
option IpVersion '4'
option RtTable '111'
option RtTableDefault '112'

config LoadPlugin
option library 'olsrd_arprefresh.so.0.1'

config LoadPlugin
option library 'olsrd_nameservice.so.0.3'

config LoadPlugin
option library 'olsrd_txtinfo.so.0.1'
option accept '0.0.0.0'

config Interface
list interface 'lan backbone'
option speed '6'

config Hna4
option netaddr '10.87.7.0'
option netmask '255.255.255.0'

…Ah, dimenticavo. in /etc/rc.local, quì a Cosenza, eliminiamo la blackhole a 10.0.0.0; abbiamo preparato un posto al caldo lì, non rinunciateci, vi stiamo aspettando.

Inoltre Capizzanux vede Cerisano a circa 5km di distanza, chi di Cerisano cogliesse la palla al balzo si aggiudicherà un peer su misura… Magari gli sistemiamo una bella Rocket su un palo telescopico nuovo di zecca, mantenuto da sostegni per montature pesanti, insomma, come diciamo qui a Cosenza: vai mò.